Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> IntelliSense problems
jchase520
post Jul 5 2011, 11:31 PM
Post #1


Newbie
*

Group: Members
Posts: 13
Joined: 5-July 11
Member No.: 5,903



Im using MS visual studio 2010 PRoofessional version , and in both languages I'm using (C++ and UnrealScript with Nfringe ) there seems to be no auto complete , also with the nfringe there is no auto indentation either .

I was wondering how to fix this?
Go to the top of the page
 
+Quote Post
280Z28
post Jul 6 2011, 09:40 AM
Post #2


Pixel Mine Developer
Group Icon

Group: Pixel Mine
Posts: 364
Joined: 29-May 08
Member No.: 1,453



The IntelliSense for each language available in Visual Studio is controlled separately, so I can only help with the one for UnrealScript.

Can you check on the following items?
  • Which version of nFringe do you have installed, as shown on the Visual Studio Help->About dialog in the "Installed products" section?
  • Did you set up your UnrealScript project according to the instructions on the UDK Projects setup page?
  • When you open an UnrealScript class file, what color is the syntax highlighting for the word "Class" (with a Capital C)?

The autocomplete dropdown should appear after you type a . (dot), or if you hit Ctrl+Space. Your cursor should move to the correct location whenever you hit Enter. nFringe does not currently support the "Automatically format code on paste" and "Automatically format code after typing '}' or ';'" options you may have seen in the C# language previously.
Go to the top of the page
 
+Quote Post
jchase520
post Jul 6 2011, 06:34 PM
Post #3


Newbie
*

Group: Members
Posts: 13
Joined: 5-July 11
Member No.: 5,903



Yes Im following along with the EAt 3d dvd on unreal scripting with nfringe so they showed us how to set up our project by cotting the project and solution files and saving them in the soruce folder .

ANd yes the udk engine stuff now shows up after I did that .

class is blue in the unrealscript file im using . some of the stuff has syntext higling but things like var, string and byte dont for some reason. and nothing has auto complete or auto indent working .,







Microsoft Visual Studio 2010
Version 10.0.30319.1 RTMRel
Microsoft .NET Framework
Version 4.0.30319 RTMRel

Installed Version: Professional

Microsoft Office Developer Tools 01018-532-2002102-70575
Microsoft Office Developer Tools

Microsoft Visual Basic 2010 01018-532-2002102-70575
Microsoft Visual Basic 2010

Microsoft Visual C# 2010 01018-532-2002102-70575
Microsoft Visual C# 2010

Microsoft Visual C++ 2010 01018-532-2002102-70575
Microsoft Visual C++ 2010

Microsoft Visual F# 2010 01018-532-2002102-70575
Microsoft Visual F# 2010

Microsoft Visual Studio 2010 Team Explorer 01018-532-2002102-70575
Microsoft Visual Studio 2010 Team Explorer

Microsoft Visual Web Developer 2010 01018-532-2002102-70575
Microsoft Visual Web Developer 2010

Microsoft Windows Phone Developer Tools - ENU 01018-532-2002102-70575
Microsoft Windows Phone Developer Tools - ENU

Crystal Reports Templates for Microsoft Visual Studio 2010
Crystal Reports Templates for Microsoft Visual Studio 2010

Hotfix for Microsoft Visual Studio 2010 Professional - ENU (KB982218) KB982218
This hotfix is for Microsoft Visual Studio 2010 Professional - ENU.
If you later install a more recent service pack, this hotfix will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/982218.

Microsoft Visual Studio 2010 SharePoint Developer Tools 10.0.30319
Microsoft Visual Studio 2010 SharePoint Developer Tools

nFringe 1.1.34.193
UnrealScript language module for Pixel Mine nFringe
Copyright Pixel Mine, Inc. All rights reserved.
Go to the top of the page
 
+Quote Post
280Z28
post Jul 6 2011, 06:44 PM
Post #4


Pixel Mine Developer
Group Icon

Group: Pixel Mine
Posts: 364
Joined: 29-May 08
Member No.: 1,453



nFringe 1.1.34 doesn't support Visual Studio 2010 very well. You'll want to update to the latest preview release of nFringe 1.2, which I just uploaded earlier today. (IMG:style_emoticons/default/smile.gif)

http://wiki.pixelminegames.com/index.php?t...Fringe:Releases

In addition, it sounds like you may have Visual Studio set to ignore nFringe:
  • In Visual Studio, select Tools > Options... > Text Editor > File Extension, and make sure uc and uci are NOT listed as extensions
Go to the top of the page
 
+Quote Post
jchase520
post Jul 6 2011, 07:20 PM
Post #5


Newbie
*

Group: Members
Posts: 13
Joined: 5-July 11
Member No.: 5,903



Ok thanks (IMG:style_emoticons/default/AECbiggrin.gif)

do i need to compeltly uninstall nfringe or jsut install over it ?

no i have no idea what visual assist is so unless it came with pro I probly don't have it lol
Go to the top of the page
 
+Quote Post
280Z28
post Jul 6 2011, 09:06 PM
Post #6


Pixel Mine Developer
Group Icon

Group: Pixel Mine
Posts: 364
Joined: 29-May 08
Member No.: 1,453



QUOTE(jchase520 @ Jul 6 2011, 07:20 PM) *
Ok thanks (IMG:style_emoticons/default/AECbiggrin.gif)

do i need to compeltly uninstall nfringe or jsut install over it ?


Just install the new version over it. (IMG:style_emoticons/default/smile.gif)
Go to the top of the page
 
+Quote Post
jchase520
post Jul 6 2011, 09:31 PM
Post #7


Newbie
*

Group: Members
Posts: 13
Joined: 5-July 11
Member No.: 5,903



Ok got it installed but there is no auto complete still . (IMG:style_emoticons/default/sad.gif)
Go to the top of the page
 
+Quote Post
280Z28
post Jul 6 2011, 10:04 PM
Post #8


Pixel Mine Developer
Group Icon

Group: Pixel Mine
Posts: 364
Joined: 29-May 08
Member No.: 1,453



QUOTE(jchase520 @ Jul 6 2011, 09:31 PM) *
Ok got it installed but there is no auto complete still . (IMG:style_emoticons/default/sad.gif)


I just realized the steps in Post #4 could have been confusing. I removed the line concerning Visual Assist - can you go back and look at the other point from that post and make sure Visual Studio is configured properly?
Go to the top of the page
 
+Quote Post
jchase520
post Jul 6 2011, 10:10 PM
Post #9


Newbie
*

Group: Members
Posts: 13
Joined: 5-July 11
Member No.: 5,903



YAAAAAAAAAYYYYYYYY it works!! \

thank you thak you (IMG:style_emoticons/default/AECbiggrin.gif)
Go to the top of the page
 
+Quote Post
280Z28
post Jul 6 2011, 10:11 PM
Post #10


Pixel Mine Developer
Group Icon

Group: Pixel Mine
Posts: 364
Joined: 29-May 08
Member No.: 1,453



Glad to hear it (IMG:style_emoticons/default/biggrin.gif)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

Lo-Fi Version Time is now: 18th November 2019 - 11:20 PM