Welcome Guest ( Log In | Register )

> NOTICE

When posting about launcher issues, please include your OPERATING SYSTEM

> How to run AE on Linux or Mac, by mefistofeles
FujiQ
post Apr 22 2008, 09:40 AM
Post #1


Marketing Manager
Group Icon

Group: Pixel Mine
Posts: 1,000,002,022
Joined: 18-November 07
From: Austin, Texas
Member No.: 17



Hi!

Here is the way to do it I've tested and got it to work fine on both MAC & Linux.

Here are the supported systems:

VirtualBox for OS X Hosts (Beta 2; Intel Macs only)

VirtualBox 1.5.2 for Linux Hosts:

Ubuntu 7.10 ("Gutsy Gibbon") i386 | AMD64
Ubuntu 7.04 ("Feisty Fawn") i386 | AMD64
Ubuntu 6.10 ("Edgy Eft") i386
Ubuntu 6.06 LTS ("Dapper Drake") i386
Debian 4.0 ("Etch") i386 | AMD64
Debian 3.1 ("Sarge") i386
Univention Corporate Server 1.3-2 instructions
openSUSE 10.3 i386 | AMD64
openSUSE 10.2 i386 | AMD64
SUSE Linux Enterprise Server 10 (SLES10) i386 | AMD64
Fedora 7 ("Moonshine") i386 | AMD64
Fedora 6 ("Zod") i386
Fedora 5 ("Bordeaux") i386
Mandriva 2008.0 i386
Mandriva 2007.1 i386
Red Hat Enterprise Linux 5 ("RHEL5") i386 | AMD64
Red Hat Enterprise Linux 4 ("RHEL4") i386
PCLinuxOS 2007 i386
Xandros Desktop 4.1 i386
All distributions i386 | AMD64

if u dont find your system here try :

linux to windows : http://www.winehq.org/
Mac to windows : http://www.vmware.com/products/fusion/features.html

Have fun an play AE on all systems (IMG:style_emoticons/default/smile.gif) (IMG:style_emoticons/default/smile.gif)

Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
reikoshea
post Apr 22 2008, 11:06 AM
Post #2


Ashen Empires Tech Wizard
***

Group: Members
Posts: 1,266
Joined: 29-March 08
From: DFW, TX
Member No.: 325



Im also going to post the way to get it to run in WINE (since most linux users already have it installed...if you do, then just skip down to how to beat the server select screen)

QUOTE
I finally got AE running through wine. Ive tested on both Ubuntu 7.04 and 7.10 (which means it should also work with debian 4.0 etch and lenny).

Just for everyone that wants to get AE working on Ubuntu/Debian

If youve already installed wine you may want to uninstall it.

I usually just use aptitude and remove the package:

sudo aptitude
/wine [enter] (press n to go to the next entry)
get to the wine package that installed and hit (-)
then hit gg.

There might be some remnant setting that will jack with the fresh install, so you might want to do the following:

(note, this will delete any file with the word wine in it. like maybe a wine list or emails that have the word wine in the subject etc. I wasnt worried about it, so i just did it).

##WARNING, if you dont know what this does, then dont do it##

sudo updatedb
sudo for i in `locate wine` ; do rm -rf $i ; done

#########################################

If you skipped the above step, then just delete the .wine directory out of your home directory.

cd ~
rm -Rf .wine

Then do the aptitude thing again:

sudo aptitude
/wine [enter]
get to the wine package labeled "wine" (+)
press gg and let it install.

Then type winecfg (make sure you arent root) and set the wine instance up as windows xp. Also, it works easier if you emulate a virtual desktop (in the graphics tab).

Once installed run the launcher, login, and press play. Once the screen minimizes fully hit ALT+F4 to close the launcher (you have to do this before the Loading image pops up. You should have the server select screen alone, and now you should be able to get it to work. You might get an error about the process terminating, but dont worry, once you select a character the message goes away.

Let me know if you have any questions. We also have confirmation that this works on Fedora linux as well.


And my second article on this when the launcher got updated.

QUOTE
Well, as some of you might have guessed, I returned to Ashen Empires. That return however, was almost cut short.

Very few of you might have noticed that the new "updated" version of wine does not work with Ashen Empires.

Apparently some of the libraries have changed...so you will have to compile your own version of wine 0.9.51. You might be able to use versions past this one...but i know for sure. 0.9.51 works in Debian 3.1, 4.0 and Ubuntu 6.10-7.10. I haven't tried any RedHat derivatives or Gentoo, but you should have similar results.


Its relatively simple. Just go to SourceForge and grab the tar ball for wine 0.9.51.

I usually put my compiled programs in /usr/local so thats what I am doing here.

# tar -xjvf wine-0.9.51.tar.bz2
# sudo mv wine-0.9.51 /usr/local/wine

I had to download a ton of stuff on my fresh installs to compile wine without any warning. I usually run installs through aptitude, but I guess for a write up a single command is easier:

# sudo apt-get update
# sudo apt-get install gcc g\+\+ flex bison fontforge libtulip-ogl-2.0-dev libproducer-dev freeglut3-dev glutg3-dev libgl1-mesa-dev ftgl-dev libotf-dev libotf0 libttf-dev libxft-dev

That will install a C and C++ compiler, fonts for wine, openGL support, and some more header files for compilation.

Before you compile, If you wish to deviate from my instructions, i'd recommend going to tools/wineinstall and modify the configs values in that script. Its pretty self explanitory.

(might need to do some chowning if you want to run this as you)
# cd /usr/local/wine
# sudo ./tools/wineinstall

Since I'm now using an old computer that process took quite sometime. Be warned.

Once the wine executable is done compiling you can enjoy your AE. For simplicity's sake i put a symlink to the new executable in my PATH that way i don't have to do a lot of typing to use it.

# sudo ln -s /usr/local/wine/wine /usr/bin/wine

And voila. Your ready to go.

# wine ~/AshenEmpires/IWG\ Launcher.exe

The launcher works pretty well...although on my Debian 3.1 and 4.0 installs I couldn't change my game directory (it had to be in ~/.wine/drive_c/Program\ Files/Iron\ Will\ Games/Ashen\ Empires). Thats a relatively small hiccup, i think.

The same trick as before is required though. Hit play, Hit ALT+F4 immediately after (to kill the Launcher window) and viola. Your server select screen should work as expected.

You are welcome to ask questions. Even when I wasn't playing, I still trolled the forums.
Go to the top of the page
 
+Quote Post

Posts in this topic
FujiQ   How to run AE on Linux or Mac   Apr 22 2008, 09:40 AM
reikoshea   Alrighty, So a new launcher is upon us, and new i...   Jun 13 2008, 08:02 AM
reikoshea   Wine 1.0 was just released. Anyone tested it yet?   Jun 20 2008, 07:33 AM
Austen the 1st   QUOTE(reikoshea @ Jun 20 2008, 07:33 AM) ...   Jun 28 2008, 05:38 AM
Seed   I had AE working in Gentoo Linux (the best linux d...   Jul 2 2008, 10:40 AM
reikoshea   Tested last night. New launcher works great using...   Dec 30 2008, 12:13 PM
Krazel   YOU ROCK <3!!!!!!!...   Dec 30 2008, 05:25 PM
reikoshea   Nice to know that me coming back added one more li...   Dec 30 2008, 06:23 PM
Krazel   I love linux, I use winxppro mainly but I have ubu...   Jan 6 2009, 02:29 AM
reikoshea   i have linux on every machine in my house (minus t...   Jan 6 2009, 02:45 PM
Krazel   Yus we should all be more Anti Microsoft srsly   Jan 7 2009, 10:37 PM
FourTwenty   Using Ubuntu and wine and trying the ALT+F4 trick,...   Apr 1 2009, 11:14 PM
FourTwenty   Update* Got it working on my own, wasnt closing t...   Apr 1 2009, 11:16 PM
Red Balron   QUOTE(FourTwenty @ Apr 1 2009, 11:16 PM) ...   Apr 1 2009, 11:18 PM
FourTwenty   This may sound idiotic but it took me 5 attempts t...   Apr 2 2009, 11:09 PM
reikoshea   I talked to Zarq about linux when I was in Austin....   Apr 3 2009, 11:02 AM
FourTwenty   PWN!!! Thx for the assist. BTW Reiko ...   Apr 3 2009, 01:15 PM
reikoshea   I dont know of any porting packages for windows-...   Apr 3 2009, 01:38 PM
GrayFox   QUOTE(reikoshea @ Apr 3 2009, 01:38 PM) I...   Apr 3 2009, 02:22 PM
reikoshea   ubuntu is the easiest choice for someone without l...   Apr 3 2009, 03:03 PM
GrayFox   QUOTE(reikoshea @ Apr 3 2009, 03:03 PM) u...   Apr 3 2009, 04:57 PM
reikoshea   QUOTE(GrayFox @ Apr 3 2009, 05:57 PM) QUO...   Apr 3 2009, 05:00 PM
Zalin   My unbuntu 8.10 and wine ran the launcher fine wit...   May 3 2009, 05:12 PM
GrayFox   QUOTE(Zalin @ May 3 2009, 05:12 PM) My un...   May 4 2009, 10:42 AM
reikoshea   yeah, if you read above at my instructions thats w...   May 4 2009, 09:17 AM
reikoshea   thanks grayfox. and just as a knowledge transfer:...   May 4 2009, 10:53 AM
The Corrupt Kitty Box   I just tried to get on, first time in 2 weeks, and...   May 27 2009, 08:00 PM
The Corrupt Kitty Box   Well I can now get to server selection without doi...   May 27 2009, 08:10 PM
reikoshea   http://forums.pixelminegames.com/index.php?showtop...   Oct 28 2009, 08:51 PM
liamdawe   Just an update for you, can someone update the pos...   Sep 3 2011, 11:25 AM
Sir Tricer   QUOTE(liamdawe @ Sep 3 2011, 11:25 AM) Ju...   Sep 26 2011, 04:35 PM
japaez   so i was reading this post, and noticed the date, ...   Jan 2 2014, 03:25 PM
reikoshea   Well since I'm back, I'll check on it toni...   Feb 11 2014, 05:11 PM
reikoshea   So, here's what I did on Ubuntu 13.04 (Termina...   Feb 11 2014, 06:50 PM
NeoGico   can someone explain how to run the Pixel Mine Laun...   Oct 31 2014, 05:26 AM
OneEye   QUOTE(NeoGico @ Oct 31 2014, 06:26 AM) ca...   Oct 31 2014, 11:58 AM
NeoGico   Thanks for the reply OneEye, I'm guessing I...   Nov 14 2014, 03:54 PM
Arktiskman   Anyone knows how to get AE working on Ubuntu 14.04...   Feb 29 2016, 05:59 PM
japaez   Just to let you know I'm about to try with the...   Dec 20 2016, 01:39 AM
japaez   Got it working with reiko's instructions they ...   Dec 20 2016, 02:47 AM
UnclePa   Void Linux, Wine 3.7. winetricks ie7 Not much luc...   May 19 2018, 11:32 AM
reikoshea   Yeah, we're unfortunately in a situation where...   May 19 2018, 09:57 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

Lo-Fi Version Time is now: 12th December 2019 - 06:07 PM